Problem
Vid enstaka tillfällen händer det att en användare plötsligt inte längre kan logga in i EDP Vision eller att det uppstår problem vid laddning av information i någon vy i samband med att användaren loggat in.
Följande felmeddelande kan visas "The given key was not present in the dictionary.":
Version: 1.34.0.5
Aktuell bild: MainForm
System.ServiceModel.FaultException: The given key was not present in the dictionary.
Server stack trace:
vid System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
vid System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) vid System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
vid System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)
Exception rethrown at [0]:
vid EDP.Framework.v2.Communication.Core.ProxyInvocationDispatcher`1.DispatchInvocation(String methodName, Object[] args) vid MyType.SaveDataSet(SecurityDataSet , TransactionEventHandler ) vid EDP.Framework.Client.Security.SecurityF.SaveRole() vid System.EventHandler.Invoke(Object sender, EventArgs e) vid System.Windows.Forms.Control.OnClick(EventArgs e) vid System.Windows.Forms.Button.OnClick(EventArgs e) vid EDP.Framework.Client.Controls.EDPButton.OnClick(EventArgs e) vid System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent) vid System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) vid System.Windows.Forms.Control.WndProc(Message& m) vid System.Windows.Forms.ButtonBase.WndProc(Message& m) vid System.Windows.Forms.Button.WndProc(Message& m) vid System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam
Orsak
Felet kan bero på något fel i cachning av information på servern.
Lösning
VertiGIS arbetar vidare med felsökning för att identifiera vad som orsakar att användarinformationen som cachats blir felaktig.
- Be IT att starta om tjänsten EDPVisionServer.
- Systemansvarig kan prova att dra ut användaren ur sin huvudroll, spara och dra in användaren i rollen igen under System>Inställningar>Behörigheter.
- För att komma runt felet finns databasuppdateringsfunktionen Rensning av cachar. Den nås via menyn under System>Databasuppdateringar. Använd den för att få användarens inloggning att fungera.
När problemet uppstår kan systemansvarig klicka på alla tre knapparna Användare, Security och Subsecurity i databasuppdateringsfunktionen Rensning av cachar, därefter kan användaren försöka logga in.
Kommentarer
0 kommentarer
logga in för att lämna en kommentar.