Problem
Vid exempelvis flytt av fastighetsdatabasen till annan server eller liknande i kopplingen GEOSECMA for ArcGIS fungerar det inte längre att hämta uppgifter till EDP Vision. Följande felmeddelande visas:
"The server was unable to process the request due to an internal error. For more information about the error, either turn on IncludeExceptionDetailInFaults (either from ServiceBehaviorAttribute or from the <serviceDebug> configuration behavior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft .NET Framework SDK documentation and inspect the server trace logs."
Orsak
Felet uppstår när fastighetsdata från markerat urval i GEOSECMA ska hämtas in till EDP Vision.
Lösning
- För att få reda på status för anslutningen från EDP Vision finns ett testprogram för webbtjänsten som heter EDPGISInformationExchangeTest.exe. Den hittas under katalogen EDPGisWS_Tester på EDP Visions applikationsserver. Kör exe-filen och tryck på knapparna uppifrån och ner. Om allt fungerar som det ska står det success i samtliga fält:
- I loggfilen RealEstateDataProvider.log som hittas under katalogen log i installationskatalogen till EDP Real Estate Data Provider bör det gå att utläsa vad som kan ha skett i kopplingen när fastighetsdata skall hämtas in till EDP Vision från GEOSECMAs fastighetsdatabas. Normalt är EDP Real Estate Data Provider installerad under D:\EDP\EDP Real Estate Data Provider eller C:\Program Files\EDP\EDP Real Estate Data Provider på EDP Visions applikationsserver.
Om t.ex. fastighetsdatabasen för GEOSECMA har flyttats så behöver även anslutningssträngen till denna uppdateras i filen EDP.RealEstateDataProvider.WindowsServiceHoster.exe.config, därefter behöver också Windows-tjänsten EDP Real Estate Data Provider startas om.
Kommentarer
0 kommentarer
logga in för att lämna en kommentar.