Problem
Vid programstart kommer meddelandet:
"Konfiguration för GDPR-loggning är felaktig, kontrollera konfiguration på server och klient."
Orsak
Förändringar i den interna miljön sedan programmet installerades.
Lösning
Kontakta IT som får kontrollera att korrekt version av .NET är installerat på applikationsservern. Har felaktiga eller flera versioner installerats ska dessa avinstalleras innan korrekt version installeras på nytt. Starta om tjänsten EDPVisionServer samt berörda applikationer efter installation.
Rätt förutsättningar för att loggningen ska fungera är:
- .NET Framework 4.8 (behöver finnas installerat på EDP Visions applikationsserver samt alla klienter).
- .NET Runtime 8 ska finnas på servern.
- ASP.NET Core Runtime 8 ska finnas på servern.
- Det tjänstdrivande kontot måste ha behörigheter till GDPR-mappen på servern.
- Rätt config för både server och klient.
Det vill säga dessa raderna ska vara konfigurerade med korrekt port.
Ersätt [servernamn] med serverns namn och [port] med porten du vill använda. (Standardport är 50100). Configraderna ska ligga under <appSettings> både på klient och server.
Server: I Vision.Business.Service.exe.config
<add key="GDPRLogHostingAdress" value="http://[servernamn]:[port]" />
<add key="GDPRLoggingAdress" value="http://[servernamn]:[port]/GDPRLogging" />
Klient: I EDPVision.exe.config
<add key="GDPRLoggingAdress" value="http://[servernamn]:[port]/GDPRLogging" />
Kommentarer
0 kommentarer
logga in för att lämna en kommentar.