Lors de l'exportation Interlis avec le GEONIS Data Converter, il est possible de rencontrer des messages d'erreur « Out of memory ». Ce message d'erreur peut ressembler à ceci, bien que le message exact puisse varier en fonction de la configuration :
Log:
2023-07-11 08:58:36| 84.2| 0.0|INFORM|Abwasserknoten_Filter_Condition_12 (TestFactory): Tested 1 of 1 bulk features
2023-07-11 08:59:15| 114.4| 30.2|FATAL |Insufficient memory available -- error code was 2 - please read the FME Help section 'Adjusting Memory Resources' for workarounds.
Cause
Ces messages peuvent se produire notamment avec de grandes bases de données et lors des exportations vers SIA405 2015 ainsi que VSA DSS 2015/2020. Cela est dû au fait que l'exportation ne peut pas libérer suffisamment de RAM pour effectuer l'opération.
Il est important de s'assurer qu'il s'agit bien d'un problème de mémoire insuffisante. Le système libère continuellement de la mémoire tout au long du processus, et il est fréquent que des erreurs ou des messages « Out of memory » apparaissent sans être la cause principale de l'échec de l'exportation.
Cela peut être vérifié en effectuant des tests avec une autre base de données plus petite en utilisant le même support et le même export. Il est également possible de vérifier la présence d'erreurs supplémentaires dans le fichier journal qui pourraient entraîner l'échec de l'exportation.
Solution
- Assurez-vous qu'il y a suffisamment d'espace mémoire disponible sur votre ordinateur, ou essayez de réaliser l'exportation dans un autre environnement. Il peut également être utile de faire l'exportation dans un environnement Windows 11, si disponible.
- Assurez-vous d'utiliser la bonne version de FME ; dans ce cas, la version 2021.1.2 est généralement la plus stable. Suivez les étapes recommandées dans l'article de FME : https://docs.safe.com/fme/html/FME-Form-Documentation/FME-Form/Workbench/memory_resources_adjusting.htm
- Assurez-vous que votre base de données est propre. Les problèmes de mémoire insuffisante peuvent souvent être causés par des données défectueuses. Effectuer des validations GEONIS ou nettoyer manuellement les données avant l'exportation peut résoudre le problème. Il est important de vérifier les géométries nulles, les tables incomplètes ou les valeurs obligatoires, ainsi que les mises à jour DB incomplètes.
- Essayez de tester avec la version Python Esri ArcGis Python 2.7 au sein du Workbench. Cela peut être réalisé en ouvrant le fichier .fmw d'exportation trouvé dans le dossier Dataconvert de votre répertoire de médias, puis en ajustant le paramètre sous Workspace-Parameters > Scripting > Python Compatibility.
- Sous « Variables d'environnement » dans le Panneau de configuration de votre ordinateur, vérifiez si la taille du tas FME est définie sur ces valeurs :
Si aucune de ces étapes ne résout le problème, veuillez contacter votre équipe de support GEONIS. Les informations importantes à joindre sont votre fichier journal d'exportation, votre fichier journal GEONIS Desktop en mode Debug (https://support.vertigis.com/hc/en-us/articles/5084318683666-GEONIS-expert-Working-with-the-GEONIS-Desktop-Log), ainsi que toutes les informations supplémentaires que vous avez recueillies lors de vos tests.
Dans la plupart des cas, le support technique demandera également votre base de données pour effectuer des tests locaux.
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