Problem
When exporting with Interlis using the GEONIS Data Converter, you may encounter "Out of memory" error messages. This error message may look something like this, although the exact message can vary depending on the configuration:
Log:
2023-07-11 08:58:36| 84.2| 0.0|INFORM|Abwasserknoten_Filter_Condition_12 (TestFactory): Tested 1 of 1 bulk features
2023-07-11 08:59:15| 114.4| 30.2|FATAL |Insufficient memory available -- error code was 2 - please read the FME Help section 'Adjusting Memory Resources' for workarounds.
Cause
These messages can especially occur with larger databases and exports to SIA405 Abwasser 2015 as well as VSA DSS 2015/2020. This is caused by the export not being able to free up enough RAM to complete the operation.
It is important to ensure that it is indeed an Out of Memory issue. The system continuously frees up memory throughout the process, and often Out of Memory errors or messages can appear without being the main trigger for a failed export.
This can be verified by testing with a different, smaller database using the same medium and export. It can also be checked by analyzing the log file for additional errors that might lead to the export failure.
Solution
- Ensure that there is actually enough available memory on your computer, or try performing the export in a different environment. It may also be helpful to perform the export in a Windows 11 environment, if available.
- Make sure you are using the correct FME version; in this case, 2021.1.2 is generally the most stable. Follow the steps recommended in the FME article: https://docs.safe.com/fme/html/FME-Form-Documentation/FME-Form/Workbench/memory_resources_adjusting.htm
- Ensure that your database is clean. Often, Out of Memory issues can arise from faulty data. Performing GEONIS validations or manually cleaning the data before an export can resolve the problem. It is important to check for null geometries, incomplete tables or mandatory values, as well as incomplete DB updates.
- Try testing with the Esri ArcGIS Python 2.7 version within the Workbench. This can be done by opening the .fmw export file found in the DataConvert folder of your media directory and then adjusting the setting under Workspace Parameters > Scripting > Python Compatibility.
- Under "Environment Variables" in your computer's System Control Panel, check that the FME heap size is set to these values:
If none of these steps resolve the issue, please contact your GEONIS support team. Important information to include are your export log file, your GEONIS Desktop log file in debug mode (https://support.vertigis.com/hc/en-us/articles/5084318683666-GEONIS-expert-Working-with-the-GEONIS-Desktop-Log), as well as any additional information you have gathered during your tests.
In most cases, the support staff will also ask for your database to perform further tests.
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