Problem
Bei aktivierter Firewall kann der Client keine Verbindung zum Lizenzmanager aufbauen. Ein Ping ist aber erfolgreich also die physikalische Maschine ist prinzipiell erreichbar.
Ursache
Ohne Anpassung nutzen sowohl der VertiGIS als auch der Esri Lizenzmanager immer dynamische Ports die aber i.d.R. durch eine Firewall blockiert werden.
Lösung
Zur Fixierung der Ports im VertiGIS Lizenzmanager:
Öffnen Sie Windows Explorer und greifen Sie auf den Installationsordner des Lizenzmanagers zu (standardmäßig C:\Program Files (x86)\Common Files\SynerGIS Shared\Lizenzen), in dem sich die Datei "synergis.lic" befindet. Öffnen Sie die Datei mit einem Texteditor. Die Datei sieht in etwa wie folgt aus:
SERVER this_host 000AE47FD25F
VENDOR SYNERGIS
USE_SERVER
FEATURE SYN_TRANSFORM SYNERGIS 1.0 05-may-2015 25 BORROW DUP_GROUP=UD \
SIGN=366B47B4A640
Hinweis:
Am Ende der ersten Zeile können Sie eine Portnummer angeben. Fügen Sie in der Zeile VENDOR den Text PORT=#### hinzu, wobei #### eine von Ihnen vergebene Portnummer ist, um den VENDOR-Daemon auf diesen bestimmten
Port festzulegen (Sperre), z. B. 2705. Nachdem Sie die Änderungen vorgenommen haben, sollte die Datei "synergis.lic" wie folgt aussehen:
SERVER this_host 000AE47FD25F 27005
VENDOR SYNERGIS PORT=2705
USE_SERVER
FEATURE SYN_TRANSFORM SYNERGIS 1.0 05-may-2015 25 BORROW DUP_GROUP=UD \
SIGN=366B47B4A640
Speichern Sie die Datei.
Klicken Sie im SynerGIS Lizenmanager und "Start/Stop/ReRead" auf ReRead License File.
Der VENDOR-Daemon ist jetzt statisch, also auf den angegebenen Port festgelegt. Diese Ports können in der Firewall jetzt als Ausnahmen gespeichert werden, um die Kommunikation zwischen dem Lizenzserver und dem Client zuzulassen.
Zur Fixierung der Ports im Esri Lizenzmanager:
Die angegebenen Schritte erfordern, dass Sie den Lizenzmanager kurz beenden. Es kann sein, dass Verbindungen zum Lizenzmanager während dieses Zeitraums getrennt werden.
Klicken Sie auf "Start" > "Programme" > "ArcGIS" > "Lizenzmanager" > "License Server Administrator". Wählen Sie im Inhaltsverzeichnis die Option "Lizenzdienst starten/beenden", und klicken Sie auf "Beenden". Öffnen Sie Windows Explorer, und greifen Sie auf den Installationsordner des Lizenzmanagers zu (standardmäßig C:\Programme\ArcGIS\License10.0\bin), in dem sich die Datei "service.txt" befindet. Die Datei sieht in etwa wie folgt aus:
SERVER this_host ANY
VENDOR ARCGIS
FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
Hinweis:
Am Ende der ersten Zeile können Sie direkt nach ANY eine Portnummer angeben. Fügen Sie in der Zeile VENDOR den Text PORT=#### hinzu, wobei #### eine von Ihnen vergebene Portnummer ist, um den VENDOR-Daemon auf diesen bestimmten
Port festzulegen (Sperre), z. B. 1234. Nachdem Sie die Änderungen vorgenommen haben, sollte die Datei "service.txt" wie folgt aussehen:
SERVER this_host ANY 27001
VENDOR ARCGIS PORT=2701
FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
Speichern Sie die TXT-Datei. Klicken Sie im License Server Administrator auf "Starten". Der VENDOR-Daemon ist jetzt statisch, also auf den angegebenen Port festgelegt. Diese Ports können in der Firewall jetzt als Ausnahmen gespeichert werden, um die Kommunikation zwischen dem Lizenzserver und dem Client zuzulassen.
Achtung: Beim parallelen Einsatz des Esri und VertiGIS Lizenzmanagers müssen jeweils verschiedene Ports verwendet werden.
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