Skip to main content


1 comment

  • Drew Millen
    Hi Chris,   I see that the ConnectionString for your map service is set up as "(http://gis/arcgisoutput/Flex_test_MapServer) http://gis/arcgisoutput/Flex_test_MapServer ".  Is this the URL to the REST endpoint for your map service as published by the ArcGIS Server REST API?   It looks like you may also need to format the syntax of your ConnectionString as per the documentation in the Site XML Reference shipped with Geocortex Essentials.  From the Start Menu > Programs > Latitude Geographics > Geocortex Essentials VERSION > REST Elements > Site XML Reference.  In the reference, you can navigate to the documentation for the Connection String attribute of the MapService element which provides a good level of detail required to configure this attribute.   Once you've set up your connection string appropriately, if it's still not working I would suggest setting your system log level to DEBUG, then consulting the log files.  In the web.config section of the REST API (C:\Inetpub\wwwroot\Geocortex\REST <VERSION>\Web.config).   Look for the following tag:   <geocortexEssentials>


        <logger systemLogLevel="WARN" accessLogLevel="INFO" />


      </geocortexEssentials>   And modify the systemLogLevel attribute to "DEBUG".  Then, when restarting your IIS instance if any sites fail to load, detailed log information will be written in C:\Inetpub\wwwroot\Geocortex\REST <VERSION>\App_Data\Logs. 


    I hope this helps!



Please sign in to leave a comment.