Zum Hauptinhalt gehen

"Internal Server Error" when I try to save

Geplant

Kommentare

12 Kommentare

  • Offizieller Kommentar
    Ryan Cooney

    Hi Adrianna,

    I am able to replicate the issue. I have logged it as issue #180651.

    There is a bit of a clumsy workaround you can use today to get past this. When this error happens:

    1. Click the "Add Data Source..." button
    2. A wizard will pop up
    3. Click "Next"
    4. Click "Cancel"
    5. Now you will be able to save

    The underlying problem is that there is an expired token being sent on the Save request. These specific workaround steps provide a way to force that token to update.

    --Ryan

  • Gareth Evans

    Hi Adrianna

    This is the first I've heard of this issue on save. We've seen issues where loading specific reports containing Rich Text Controls throws this error. I'd agree this is serious, not being able to save a report would make the product much less useful.

    Please give us some details:

    • which version of VSR are you using (Designer > Help > bottom of panel)
    • Which Identity provider are you using, AGOL or AGE on-prem (and which version)?
    • are all reports affected, or only specific ones?
    • Regarding your order of steps to reproduce this issue, is this accurate:
    1. Open existing report OR create new report
    2. modify report (move item in designer, or modify any activity's properties)
    3. File > Save
    4. user sees error
    0
  • Adrianna Barton

    Hi Gareth, 

    I am using VertiGIS Studio Reporting Version 5.16.0, accessed through https://apps.geocortex.com

    AGOL as identity provider

    all reports are affected, my coworker is having the same issue as well

    I will start editing an existing report, save repeatedly and after about 25 minutes I will try and save and get the "Internal server error" red banner across the bottom. I believe it is logging me out/expiring when this happens and I'm not sure why. 

    0
  • Adrianna Barton

    Thank you Ryan!!! That is super helpful, thank you for logging the issue as well:)

    0
  • Gareth Evans

    Thanks Ryan!

    Another alternative workaround would be to use the Export menu, which gets a fresh token in the background. You also get the added benefit of a 'backed up' export of the report.

    1. File > Export
    2. Export report.
    3. Now you will be able to save.
    0
  • Ryan Cooney

    Just an update that this issue has been fixed for the 5.17 release and will be available in a couple weeks.

    --Ryan

    1
  • Adrianna Barton

    Hello, I am now having a very similar issue with online version 5.19.0. When I save-as a report I get this error when I edit it and try to save my edits. I have tried using VertGIS in chrome an microsoft edge, getting the issue in both. Seems to be necessary to completely close out and re-login when I save-as a report, which is quite inconvenient.

     

    1
  • Trevor Oatts

    I have also gotten the error when trying to save: "Item does not exist or is inaccessible" , and then it closes me out of my report and I am unable to open it or edit it again. I have found that logging out of portal and then re-opening the reporting designer and logging back in has helped.

    0
  • Eric Kriener

    This has been happening to me for quite a while now as well.

    I just upgraded to 5.21 this morning and the first time I tried to save got the error. 

    I've tried it in different browsers, incognito mode, on different computers...

    I got it to save once yesterday by stopping and starting the app pool but it didn't even save once after upgrading and rebooting the whole machine this morning.

    and neither @... or Gareth Evans workarounds work.

    0
  • Gareth Evans

    Hey Eric Kriener the issue you're seeing there looks to be slightly different from the one described by others in this thread.

    I see you have submitted support ticket #49853 - thanks for doing that!

    I briefly glanced at this HAR, noted that we see a response for https://maps.sarpy.gov/Geocortex/Reporting/editor/ReportDesigner/Invoke that is error "Internal Server Error" - not clear why this happens.

    I'd be curious if this occurs with all reports or just specific ones.

    It seems to me that this an issue on the VSR server at the application level. There may also be some value in looking at the Windows Event Viewer logs for the Application heading, as the issue appears to be around the Application Pool running on your VSR server.

    0
  • Eric Kriener

    It happened for 3 of the 4 reports I tried this morning.
    There aren't any errors that reference VSReporting in my event viewer.

    0
  • Eric Kriener

    It also seems that it's reports that I create using the new "Layer Report" bomb out, but if I use the "Blank Report" it works...

    0

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.