Problem
Der 3A Server Dienst kann nicht gestartet werden.
Auszug WindowsService.log:
...
2022-08-08 09:03:08,534 ERROR - Fehler beim Schließen existierender NAS Prozesse. Bitte prüfen Sie, ob das Auftragsmanagement (IIS) gestartet wurde.
System.Net.WebException: Fehler bei der Anforderung mit HTTP-Status 503: Service Unavailable.
bei System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
...
Ursache
Das Auftragsmanagement des 3A Server konnte nicht gestartet werden.
Bitte zunächst über ein Datenbank-Login, z.B. mittels sqlplus (Oracle) bzw. psql (PostgreSQL), ob der Benutzer, dem das Auftragsmanagement gehört/gehören soll, grundsätzlich zur Verfügung steht.
Beispiel für Oracle:
Können Sie sich mit sqlplus mit dem Schema des Auftragsmanagement (Schema Owner) verbinden?
sqlplus <ora_auftrags_nutzer/<ora_auftrags_passw>@<net_service_name>
laut Verbindungsparameter (3A-Server.conf) zur Auftragsdatenbank:
<name>AaaServer.AuftragsManager.ConnectionORA</name>
<value>UserId=<ora_auftrags_nutzer; Password=<ora_auftrags_passw>; DataSource=<net_service_name></value>
Falls ja, hier weiterhin eine mögliche Ursache und die Lösung zum Problem mit der Bitte um folgende Überprüfung:
Der Fehler tritt auf, wenn der sogenannte "DefaultAppPool" nicht gestartet werden kann. Dies ist z.B. der Fall, wenn das Passwort des Benutzers, unter dem dieser läuft, abgelaufen oder falsch ist. Ggf. ist die Rechtevergabe im Zusammenhang mit diesem Benutzer geändert worden. Bitte überprüfen.
Lösung
Starten Sie den Internetinformationsdienste-Manager über: Start "Internetinformationsdienste-Manager“. Navigieren Sie zu
<Rechnername>(<Rechnername>\<Benutzerkennung> -> Anwendungspools
Klicken Sie mit der rechten Maustaste auf „DefaultAppPool“. Hat dieser den Status gestartet, bitte ggf. starten. Wenn dies nicht geht -> Erweiterte Einstellungen
3A Server Professional:
Über die drei Punkte rechts gelangt man in die Benutzereinstellungen (Identität des Anwendungspools). Ist dort eingestellt?:
Integriertes Konto -> ApplicationPoolIdentity
Wenn nicht stellen Sie dies dort ein und versuchen Sie einerneutes Starten des „DefaultAppPool“. Sie können dort auch einen konkreten Admin-Benutzer einstellen (s.u.).
3A Server Public:
Ist dort ein konkreter Admin-Benutzer eintragen? Dieser Admin-Benutzer sollte über umfassende Rechte im Umfeld von 3A Web ALKIS Auskunft verfügen (siehe Inbetriebnahmeanleitung 3A Server) und z.B. auch die NBA-Nachverarbeitung starten können:
Falls das Kennwort zu diesem Benutzer abgelaufen sein sollte, bitte für diesen Benutzer ein neues Passwort setzen und dieses Passwort in der Benutzerkontoverwaltung auf "Kennwort läuft nie ab" stellen.
Start -> Computerverwaltung -> Lokale Benutzer und Gruppen -> Benutzer
Nach dem erfolgreichen Starten des "DefaultAppPools" bitte die 3A Server Dienste noch einmal versuchen zu starten.
In der Inbetriebnahmeanleitung des 3A Servers, Kapitel "Typische Probleme bei der Inbetriebnahmeanleitung", finden Sie weitere Fehlermeldungen mit zugehörigen Lösungsvorschlägen beschrieben, die bei Inbetriebnahme bzw. beim Start des Servers auftreten können.
Kommentare
0 Kommentare
Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.